[Linux-uvc-devel] Patch for USB problem with Logitech webcams?

Laurent Pinchart laurent.pinchart at skynet.be
Tue Aug 14 21:18:25 CEST 2007


Hi Morten,

On Monday 13 August 2007, Morten Mortensen wrote:
> Hi Laurent & all
>
> Regarding Logitech-problems, I have just been trying out a number of UVC
> revisions tonight. As you suggested.

If I had known you would report so much information I might not have suggested 
that ;-) (just kidding, I've had a long day at work).

> First, I must admit, that my current kernel somehow has advanced from
> the below mentioned "2.6.21-1.3228.fc7" to a 2.6.22 version; I must have
> accepted one of the "updates" within FC7 without paying attention.

You might want to try vanilla kernels too. Distributions ship patches that 
sometimes disturb external kernel modules.

> With this kernel 2.6.22, I am unable to reproduce any Logitech webcams
> working "for periods of multiple minuttes at a time". I have tried
> revisions 120, 119, 118, 115, 114, 112, 111, 110, 92

So this is more likely a kernel issue. As if there wasn't enough space for 
bugs to hide in the UVC driver :-)

> (I also tried to check out revisions 117, 116, 113 and 91, but the
> subversion client apparently just... hanged).

Weird...

> I have kept the revisions in separate directories. I have done a lot
> of "modprobe -r uvcvideo", "make", "make install", "modprobe uvcvideo" to
> shift between the revisions.

You might find it easier to load the module with insmod. That way you won't 
have to "make install" it.

> There are minor differences, bot common for all these revisions are, that
> both my Logitech Fusion and my Logitech Ultra Vision fails within five
> seconds. I do not see any complete, stable images as seen on screen with
> "luvcview". The images have either large rectangles with noise or many
> small rectangles with noise; the images look really bad.

What do you mean by "fail" ? Do the webcams continue streaming bad images, or 
does luvcview stop and print an error message ? If it stops, what's the error 
message ? Do you then get a message in the kernel log ? Which image 
resolution have you used ?

> The somewhat better results as mentioned below from around Friday 20.
> July and with the 2.6.21 kernel I can not reproduce. I wonder if this
> kernel is still floating around upon my system, so I can make grub boot
> with it??

I have no experience with FC so I can't tell. If you're familiar enough with 
Linux kernels, I'd suggest trying the vanilla kernel (which you'll have to 
compile yourself).

> Together with the two Logitech webcams I have attached a Creative Optia
> AF. The video-stream from this Optia AF webcam is pretty stable
> throughout all the revisions tried tonight. However, the stream does
> tend to produce a single bad image with an interval of about 5-10
> seconds. From some point in the middle of the frame, the rest of the
> frame does not look right. Except from this, the video-stream from the
> Creative webcam is really, really good.

Errors can happen when a packet is lost or otherwise corrupted. There's not 
much we can do there.

Early Logitech UVC webcams are known to suffer from timing issues, so I'm not 
surprised the Optia AF works better.

> I have also tried playing around with the Logitech webcams and image
> sizes - just to see if I could trigger some better or worse response.
> The one Logitech would not display 960x720, while trying to access the
> second with this resolution made my computer lock up completely! No more
> keyboard or mouse. Pressing the power-button on the chasses did produce
> some kind of fc-shutdown dialog, but still with no keyboard. I have
> mouse and keyboard attached through USB, not PS/2. This was with
> revision 120.

Your kernel might have crashed in an interrupt handler. You will have to 
compile the kernel with serial console or net console support to get the oops 
message on the serial console or on the network.

> As of right now, I can not reproduce any of my Logitech webcams working
> "for periods of multiple minuttes". But they did, once.

As this is probably a kernel issue, could you try with vanilla 2.6.21 (and, if 
it still doesn't work, with vanilla 2.6.22) ?

> Below is a listing of the kernel version (I am running Fedora 7 - and my
> installation should be completely up-to-date) together with a listing of
> the USB devices and the hieracy. The three webcams have at all times
> been attached through a USB hub.

Could you try attaching a Logitech webcam directly to your computer and see if 
it works better ?

Best regards,

Laurent Pinchart



More information about the Linux-uvc-devel mailing list